Xubuntu Documentation
Copyright © 2012–2017 The Xubuntu documentation team. Xubuntu and Canonical are registered trademarks of Canonical Ltd.

Credits and License

This documentation is maintained by the Xubuntu documentation team and is partly adapted from the Ubuntu documentation.

The contributors to this documentation are:

... David Pires (slickymaster)
... Elfy (elfy)
... Elizabeth Krumbach (lyz)
... Jack Fromm (jjfrv8)
... Jay van Cooten (skippersboss)
... Kev Bowring (flocculant)
... Krytarik Raido (krytarik)
... Pasi Lallinaho (knome)
... Sean Davis (bluesabre)
... Stephen Michael Kellat (skellat)
... Steve Dodier-Lazaro (sidi)
... Unit 193 (unit193)

The contributors to this translation of the documentation are:

... Alex Katz (dumplingcloud)
... Alex (misterzixy)
... Andi Chandler (bing)
... Pasi Lallinaho (knome)
... Stephan Woidowski (swoidowski)

The contributors to previous versions to this documentation are:

... Cody A.W. Somerville (cody-somerville)
... Freddy Martinez (freddymartinez9)
... Jan M. (fjam7)
... Jim Campbell (jwcampbell)
... Luzius Thöny (lucius-antonius)

This document is made available under the Creative Commons ShareAlike 2.5 License (CC-BY-SA).

You are free to modify, extend, and improve the Ubuntu documentation source code under the terms of this license. All derivative works must be released under this license.

This documentation is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE AS DESCRIBED IN THE DISCLAIMER.

A copy of the license is available here: Creative Commons ShareAlike License.
All trademarks or registered trademarks are the property of the respective owners.
Welcome!

This documentation provides information on some of the most common topics on using Xubuntu, including:

Chapter 7, Connecting to Internet and Networks

Chapter 9, Managing installed applications

In addition, this documentation has three quick guides:

Chapter 3, Getting to know your desktop environment

Chapter 5, Quick guide to default applications

Chapter 11, Keeping your computer and personal information safe

The complete set of topics is listed below. If you require help with a topic or problem that is not addressed by the documentation, go to the Help & Support [http://xubuntu.org/help/] page of the Xubuntu website. There you will find links to additional help resources.

If you would like to contribute to Xubuntu, including this documentation, see the Get Involved [http://xubuntu.org/contribute/] section of the Xubuntu website.
# Table of Contents

1. What is Xubuntu? .......................................................................................................................... 1
   - A short introduction .................................................................................................................. 1
     - Xubuntu is a community-developed, Ubuntu-based Linux operating system. .................. 1
   - About the name ...................................................................................................................... 1
   - Version numbering ................................................................................................................. 1
   - Learn more about what makes Xubuntu .............................................................................. 1
     - Free Software ..................................................................................................................... 1
     - Linux ................................................................................................................................. 1
     - Xfce ................................................................................................................................. 2

2. Migrating and Upgrading ........................................................................................................... 3
   - Migrating from Windows ...................................................................................................... 3
     - A quick Windows–Xubuntu dictionary .............................................................................. 3
     - Windows applications on Linux ...................................................................................... 3
     - Windows networking on Linux ....................................................................................... 3
   - Upgrading Xubuntu ............................................................................................................... 4
     - Upgrading to the next available release .......................................................................... 4
     - Changing your upgrade path ......................................................................................... 4
     - Upgrading to the development version .......................................................................... 5

3. Getting to know your desktop environment ............................................................................... 6
   - Desktop .................................................................................................................................. 6
   - The Panel ............................................................................................................................. 6
   - The Desktop ......................................................................................................................... 6
   - Files and directories ............................................................................................................. 6
   - Navigation ............................................................................................................................ 6
   - Creating and deleting files and folders .............................................................................. 7
   - Copying ............................................................................................................................... 7
   - Removable devices ............................................................................................................ 7
   - Customizing Thunar .......................................................................................................... 8

4. Settings and Preferences ........................................................................................................... 9
   - Customizing the Menu ........................................................................................................ 9
   - Customizing your personal info .......................................................................................... 9
   - Customizing the appearance ............................................................................................... 10
     - Changing your wallpaper ............................................................................................... 10
     - Customizing your panel configuration ........................................................................... 11
     - Changing your desktop themes ...................................................................................... 11
     - Disabling and modifying the desktop effects ................................................................. 12

5. Quick guide to default applications ......................................................................................... 13
   - Graphics .............................................................................................................................. 13
   - Internet ............................................................................................................................... 13
   - Media ................................................................................................................................. 13
   - Office .................................................................................................................................. 14
   - System ............................................................................................................................... 14

6. Media applications .................................................................................................................... 15
   - Music ................................................................................................................................... 15
<table>
<thead>
<tr>
<th>Chapter</th>
<th>Title</th>
<th>Pages</th>
</tr>
</thead>
<tbody>
<tr>
<td>7.</td>
<td>Connecting to Internet and Networks</td>
<td>17</td>
</tr>
<tr>
<td></td>
<td>Network connections</td>
<td>17</td>
</tr>
<tr>
<td></td>
<td>Connecting and disconnecting</td>
<td>17</td>
</tr>
<tr>
<td></td>
<td>Configuring connections</td>
<td>17</td>
</tr>
<tr>
<td></td>
<td>Connection information</td>
<td>17</td>
</tr>
<tr>
<td></td>
<td>Sharing your connection to another computer</td>
<td>18</td>
</tr>
<tr>
<td></td>
<td>Dialup modems</td>
<td>18</td>
</tr>
<tr>
<td></td>
<td>Network troubleshooting</td>
<td>18</td>
</tr>
<tr>
<td></td>
<td>General troubleshooting</td>
<td>18</td>
</tr>
<tr>
<td></td>
<td>Wireless troubleshooting</td>
<td>19</td>
</tr>
<tr>
<td></td>
<td>Advanced troubleshooting</td>
<td>20</td>
</tr>
<tr>
<td></td>
<td>Connecting to servers</td>
<td>21</td>
</tr>
<tr>
<td>8.</td>
<td>Printing and Scanning</td>
<td>22</td>
</tr>
<tr>
<td></td>
<td>Printing</td>
<td>22</td>
</tr>
<tr>
<td></td>
<td>Local printing</td>
<td>22</td>
</tr>
<tr>
<td></td>
<td>Network printing</td>
<td>23</td>
</tr>
<tr>
<td></td>
<td>Scanning</td>
<td>23</td>
</tr>
<tr>
<td></td>
<td>Does my scanner work in Xubuntu?</td>
<td>24</td>
</tr>
<tr>
<td></td>
<td>Using your scanner</td>
<td>24</td>
</tr>
<tr>
<td></td>
<td>The computer says &quot;No scanners detected&quot;</td>
<td>24</td>
</tr>
<tr>
<td></td>
<td>Manually installing a scanner</td>
<td>24</td>
</tr>
<tr>
<td>9.</td>
<td>Managing installed applications</td>
<td>26</td>
</tr>
<tr>
<td></td>
<td>Using Gnome Software</td>
<td>26</td>
</tr>
<tr>
<td></td>
<td>Installing new software</td>
<td>26</td>
</tr>
<tr>
<td></td>
<td>Removing software</td>
<td>26</td>
</tr>
<tr>
<td></td>
<td>Additional software repositories</td>
<td>27</td>
</tr>
<tr>
<td></td>
<td>Enabling more repositories</td>
<td>27</td>
</tr>
<tr>
<td></td>
<td>Restricted and non-free software</td>
<td>28</td>
</tr>
<tr>
<td></td>
<td>Installing packages without an Internet connection</td>
<td>28</td>
</tr>
<tr>
<td></td>
<td>Adding discs as software sources</td>
<td>28</td>
</tr>
<tr>
<td></td>
<td>Helpful application</td>
<td>29</td>
</tr>
<tr>
<td></td>
<td>Changing update frequency and behavior</td>
<td>29</td>
</tr>
<tr>
<td></td>
<td>Update Sources</td>
<td>29</td>
</tr>
<tr>
<td></td>
<td>Notifications of new Xubuntu versions</td>
<td>29</td>
</tr>
<tr>
<td></td>
<td>Other options</td>
<td>30</td>
</tr>
<tr>
<td>10.</td>
<td>Offline Package Management</td>
<td>31</td>
</tr>
<tr>
<td></td>
<td>Updating Repositories</td>
<td>31</td>
</tr>
<tr>
<td></td>
<td>Installing a Package</td>
<td>32</td>
</tr>
<tr>
<td></td>
<td>Upgrading Your System</td>
<td>32</td>
</tr>
<tr>
<td>11.</td>
<td>Keeping your computer and personal information safe</td>
<td>33</td>
</tr>
</tbody>
</table>
Chapter 1. What is Xubuntu?

A short introduction

Xubuntu is a community-developed, Ubuntu-based Linux operating system.

Xubuntu is an elegant and easy-to-use operating system. Xubuntu comes with Xfce, which is a stable, light and configurable desktop environment.

It is perfect for those who want to make the most of their desktops, laptops and netbooks, featuring a modern look and enough features for efficient, daily usage. It works well on older hardware too.

Find out more at the Xubuntu website [http://xubuntu.org/].

About the name

The "X" in Xubuntu stands for Xfce, the desktop environment in Xubuntu. While the word "ubuntu" denotes the dependency on and usage of the Ubuntu core, it also represents the philosophical core of the operating system. A rough translation of the word ubuntu is "humanity towards others". To read more about the philosophy and ideals behind Ubuntu and Xubuntu, please refer to the Ubuntu Philosophy [http://www.ubuntu.com/project/about-ubuntu/our-philosophy] page.

In addition to using the Ubuntu core, Xubuntu also uses the infrastructure kindly provided and sponsored by Canonical Ltd. [http://www.canonical.com/], a company founded by Mark Shuttleworth.

Version numbering

The Xubuntu version numbering scheme is based on the distribution release date. The first part of the release denotes the year while the second part denotes the month. For example, the first official Xubuntu version was released in June, 2006, thus its version number was 6.06. The latest Long Term Support (LTS) version is 16.04, codenamed Xenial Xerus.

Learn more about what makes Xubuntu

Free Software

The Xubuntu project is entirely committed to the principles of free software development; people are encouraged to use free software, improve it, and pass it on. You can find out more about free software and the ideological and technical philosophy behind it at the GNU website [http://www.gnu.org/].

Linux

Linux was brought to life in 1991 by a Finnish student named Linus Torvalds. The Linux kernel is the heart of the Xubuntu operating system. A kernel is an important part of any operating system, providing
the communication bridge between hardware and software. Read more about Linux at the Linux kernel website [http://www.kernel.org/].

**Xfce**

Xfce is the lightweight desktop environment used in Xubuntu. It aims to be fast and low on system resources, while still being visually appealing and user friendly. Xfce embodies the traditional UNIX philosophy of modularity and re-usability. Read more about Xfce at the Xfce website [http://www.xfce.org/].
Chapter 2. Migrating and Upgrading

Migrating from Windows

A quick Windows–Xubuntu dictionary

Windows: Add/Remove Programs
Xubuntu: ➕ ➔ Software

Windows: Control Panel
Xubuntu: ➕ ➔ Settings Manager for personal preferences ➔ System (menu) for additional configuration

Windows: Windows Explorer
Xubuntu: ➔ Accessories ➔ File Manager

Windows: My Documents
Xubuntu: ➔ /home/username/

Windows applications on Linux

It is possible to run Windows applications under Xubuntu. Two possible choices are:

... Wine [http://winehq.org/], the Windows emulator. Wine allows running some Windows applications without having to install a Windows operating system. Refer to the Wine AppDB [http://appdb.winehq.org/] to find out which applications will run on Wine and the Wine documentation [http://www.winehq.org/help/] for FAQ’s and user support.

... VirtualBox [https://www.virtualbox.org/], virtualization software. You can install a Windows operating system along with any application into a virtual machine managed by VirtualBox. Note that 3D support on VirtualBox is still quite unreliable. To read more about VirtualBox and virtualization, refer to the VirtualBox end-user documentation [https://www.virtualbox.org/wiki/End-user_documentation].

Tip

Both Wine and VirtualBox are available in the software repositories.

Windows networking on Linux

Accessing Windows network shares under Xubuntu can be easily done using:

... ➔ Accessories ➔ File Manager, where you can browse publicly visible shares by clicking on the Network item in the sidebar. Alternatively, you can browse a remote file system by going to Go ➔ Open Location... and entering smb://computername/sharename.

... ➔ System ➔ Gigolo, which allows you to save bookmarks and manage remote file systems. To connect, click the first toolbar button. Select Windows Share from Service Type, then enter the remote share’s details.

If some options are not available or do not work, ensure that the ➔ gvfs-backends is installed.
Upgrading Xubuntu

New regular releases of Xubuntu are released every 6 months and Long Term Support (LTS) releases every 2 years. Currently, regular releases are supported for 9 months and LTS releases for 3 years.

The Software Updater will inform you when a new version for your upgrade path is available for download. To change the upgrade path, see the section called “Changing your upgrade path.”

Upgrades usually take a while to complete. Typically, around 1000 megabytes of packages must be downloaded and installed, although the actual figure will depend on how many packages are already installed on your computer.

Upgrading to the next available release

1. Go to ↪ Settings Manager → Software Updater and wait for the list of available updates to be downloaded.
2. If a new version of Xubuntu is available, a box at the top of the window will appear saying that a new distribution release is available.
3. To upgrade to the next available release, save all of your open documents and click the Upgrade button in ↪ Settings Manager → Software Updater.

Note: If you are not getting an upgrade notification, or aren't seeing the release you are expecting to upgrade to, see the section called “Changing your upgrade path.”

Changing your upgrade path

There are two main upgrade paths you can follow: either upgrade to long-term support (LTS) releases only, or upgrade to all releases.

If you decide to follow the LTS upgrade path, you will be notified of new releases every two years. If you decide to follow the regular releases upgrade path, you will be notified of new releases every 6 months. You can change from regular to LTS upgrade path once you have reached the next LTS release.

If you want to change your upgrade path, you can do it when running an LTS version. To do so, choose one of the following options:

1. Navigate to ↪ Software → Software & Updates and select the Updates tab. In the Updates tab, select either For any new version or For long-term support versions from the Notify me of a new Ubuntu version dropdown depending on your choice.

2. Open the ↪ Accessories → Terminal Emulator and run sudoedit /etc/update-manager/release-upgrades and change the line starting with prompt= to prompt=normal (for all releases) or prompt=lts (for LTS releases) depending on your choice.
Note

If you are running a regular release that is not immediately followed by an LTS release, you should not change the upgrade target to long-term support (LTS) releases only.

Caution

Upgrading an LTS version to anything other than another LTS version will lose the long term support.

Upgrading to the development version

Warning

Development releases often suffer from package breakages and other problems. Only install a development release if you are prepared to attempt to fix these problems for yourself or if you want to help the Xubuntu team by testing and giving feedback.

Note

You will need to be running the latest regular version to be able to upgrade to the version currently under development.

If you would like to install and test the latest development version of Xubuntu before it is released, run `update-manager -c -d` at the command line. This will allow you to upgrade to the current development release. Please consider getting involved [http://xubuntu.org/contribute/qa] with reporting usage of development versions and associated packages.
Chapter 3. Getting to know your desktop environment

When your computer has finished booting up, and after entering your login data, you will arrive at the Xubuntu desktop. It comes with many features designed to make your life easy, it is well worth taking the time to get to know it.

Desktop

The Xubuntu desktop has a single panel located at the top of the screen.

The Panel

The panel is used for starting and switching applications and for receiving information about your system. On the left side of the panel you will see the Xubuntu logo. Clicking on this icon will open the Menu, offering you many choices of applications. Along the bottom of the menu window are icons for Settings Manager, Lock Screen and Log Out.

The middle section of the panel is dedicated to window buttons for open applications. On the far right is the clock, displaying the date and time. To the left of that is the Notification Area. Here you will see indicators which give you information on your system, including network connectivity, sound volume level, battery status (when appropriate), instant messages. Some notification icons only appear when needed, for instance when software updates are available.

The position of the panel, the items it contains and the Menu are all customizable. See Chapter 4, Settings and Preferences for more information on those topics.

The Desktop

The default desktop has just three icons on it: Home, File System and Trash (icons for removable devices will also appear when those devices are present). You can customize your desktop by right-clicking in a blank area and choosing Desktop Settings. From here you can change the wallpaper and modify menu and icon behaviour.

Files and directories

Xubuntu comes with Xfce's file manager Thunar. For simplicity's sake, we will just refer to it as the File Manager. Load it from Accessories → File Manager or by double-clicking the Home or File System icons on your desktop.

Navigation

The File Manager's default view consists of a shortcut pane on the left side, the main area on the right, and a pathbar above the main area. The shortcut pane provides shortcuts to different folders on your system. The first shortcut under PLACES will lead to your home directory, the directory where you store
Getting to know your desktop environment

all your personal data, and will have the name of the current user. That directory will probably appear empty. The File System shortcut under Devices will take you to the root of your filesystem. You may want to explore it a bit, even though it may be confusing to you if you are new to Linux. Just click on the different folders and see what's inside. When you're done, return to your home directory by clicking on the top shortcut.

Tip
You can add your own shortcuts by simply dragging folders to the shortcut pane. This will allow you to access important folders instantly!

Tip
When using Thunar you will, in general, only have read rights to files you see while browsing under the File System shortcut.

The main area will always display the contents of the current folder. Double-click on folders to enter them, and right-click on files/folders to get a pop-up window offering you some choices of what to do with them. Select multiple files by dragging a rectangle over them with the mouse. Alternatively, select one file, hold down the Shift key, and increase/decrease the selection using the arrow keys.

To easily see the path you took to get to the current directory, you can change the default View options. From the File Manager menu, select View → Location Selector → Pathbar Style. Now you can click on any pathbar icon to change to the directory it represents. Note that right-clicking on pathbar icons will also bring up a pop-up window with some options.

Creating and deleting files and folders

To create a new document, right-click on some empty space in your home directory and select Create Document → Empty File from the pop-up menu. The File Manager will prompt you for a name. Just go with the suggested name for now. After this, you will see the new file in your home directory. Right-click on it and choose Properties. This will show you some details about the file. Right-click on the file once more and choose Move to Trash to remove it. The file will be put into the Trash.

Tip
If you ever want to undo the deleting of a file, open Trash, right-click the file and click Restore.

To create a new folder, right-click on the empty space, and choose Create Folder. You will be prompted for a name. Type something and hit Enter. You will see this new folder in your home directory. Double-click on it to enter it. To rename or remove the folder, right-click on it and choose the appropriate option from the pop-up menu.

Copying

To copy and move files on your computer, just click and drag files and folders to other folders.

Removable devices

When inserting CDs, USB sticks or other removable media into your computer, or inserting removable devices like a music player, Xubuntu should automatically detect the new device. For example, after
inserting a CD into your optical drive, you will see a new shortcut in the left pane of the **File Manager** representing the CD. Clicking on it will open the CD in the main area, just like clicking on a regular folder. To remove the CD, right-click on the shortcut, and choose *Eject*. The same applies for any other removable media.

**Note**

Please note that pressing the eject button on your CD drive may not work. This may be surprising to some users, but it is in fact the expected behavior. Before the CD can be ejected, it needs to be properly "released" (unmounted) by the system. To remove a CD, always right-click on its shortcut and choose *Eject*.

**Customizing Thunar**

There are many ways to customize the **File Manager**. If you do not like the way the icons are displayed, choose *View → View as Detailed List* to have the contents of the current directory displayed as a list.

You can have the **File Manager** display a location bar instead of the pathbar by selecting *View → Location Selector → Toolbar Style*. If you prefer a tree view in the left pane, choose *View → Side Pane → Tree*.

Finally, you can add Custom Actions, which can add useful options to the menu. Many custom actions can be found at the Ubuntu Wiki Thunar Custom Action [https://help.ubuntu.com/community/ThunarCustomActions] page.

For more choices, explore the options under *Edit → Preferences*. 
Chapter 4. Settings and Preferences

The options to customize Xubuntu to your needs and preferences are virtually unlimited, ranging from desktop looks to low level operation tweaks. The sections in this chapter describe how to edit the main applications menu to your liking, keep your personal information updated and customize the looks of the desktop.

Customizing the Menu

The easiest and probably most useful tweak you can make to the Menu is to customize your Favorites. Accomplishing this is a simple matter of locating the application you want, right-clicking on it and selecting Add to Favorites. From that same right-click popup, you can also choose to add the application to the Desktop or to the Panel. Right-clicking on applications already in Favorites gives you the option to remove them or to sort the list. You can also rearrange Favorites just by dragging them.

If you're not sure where a program is listed or what it is called, you can use the search feature. When you open the Menu, your cursor is already positioned in the search bar. Just start typing and an incremental search is performed on both application names and descriptions. Once you see your application listed in the results, you can directly launch it or right-click on it and add it to your preferred launch location.

For more options to customize the Menu, right-click on and select Properties. There you will find three tabs to change Appearance, Behavior and Search Actions.

To add directories and launchers which don't appear as entries in the default Menu, you'll need another tool. A more advanced menu editing utility called MenuLibre can be found by clicking Settings Manager → Menu Editor or by a right-click on and choosing Edit Applications. Using this editor you can create, hide and reorder the directories which appear in the right-hand pane of the Menu. Within those directories you can then create application launchers and customize their behavior by configuring the many options available in this utility. For more in-depth information on how to use all of those options, consult the MenuLibre [https://wiki.bluesabre.org/doku.php?id=menulibre-docs] online documentation.

Customizing your personal info

Mugshot is a lightweight user configuration utility that allows you to easily set the profile image and user details for your user profile and any supported applications.

To launch Mugshot navigate to Settings Manager → About Me.

To change your profile image, click the image button on the left of the GUI, select one of the given options and follow the instructions.

Note

Mugshot requires the installation of gstreamer1.0-tools package to use the Capture from camera... feature.

Fill the text-fields with the required personal data and click Apply. When applying these details with Pidgin and/or LibreOffice installed, you will be prompted to update their settings as well.
Warning

If the personal data inserted in the **First Name** and **Last Name** text-fields differ from the existing values held in `/etc/passwd`, you'll be prompted to insert your password as a security measure to prevent unwanted updates to your personal information.


Customizing the appearance

If you want to customize the appearance of your Xubuntu system, the options are many. Here are a few good starting points.

Changing your wallpaper

You can easily change your desktop wallpaper by navigating to ➜ ➜ **Settings Manager** ➜ **Desktop**, or alternatively, by right clicking on your desktop and selecting the **Desktop Settings...** option. Where you have multiple workspaces, you can choose to have the same wallpaper across all workspaces, or use a different wallpaper for each workspace by deselecting **Apply to all workspaces** and moving the dialogue to each workspace individually and selecting a different wallpaper.

Once the **Desktop** settings dialog is open, the **Background** tab gives you options for configuring the look of your desktop background. You can choose to use a single image or multiple images as wallpaper or you can use a color scheme.

Tip

The location of the images in the **Wallpaper for my desktop** pane is controlled by the **Folder:** option. By bringing up this pick list, you can choose an alternate location for the source of your images. If you want to add one or more of your images to this list for future use, you can copy or symlink them to `/usr/share/xfce4/backdrops/` (requires administrative privileges).

If you choose a location that contains multiple images, you have the option of varying the background by switching to each of the images in that location. By checking **Change the background**, you have several time-based criteria to choose from, the last of which, **Chronologically**, will sort the pictures by filename and then go through them in that order, spread out equally over one day.

Xfdesktop supports xinerama and multi-monitor setups. With more than one display/monitor connected, the **Background** tab will always reflect the settings of the monitor where the dialog is positioned. This allows each monitor to have its own settings. Just drag the dialog to the monitor on which you want to edit the settings.

If you want to set any of your own images as the wallpaper, the easiest way to achieve this is:

... Open Thunar and navigate to the directory with the image

... Right-click the image and select **Set as wallpaper** from the context menu
Settings and Preferences

<table>
<thead>
<tr>
<th>Caution</th>
</tr>
</thead>
<tbody>
<tr>
<td>With multiple monitors, this setting will only change the wallpaper for the currently active monitor. To change the wallpaper for other monitors, move the dialog to each other monitor to access their settings.</td>
</tr>
</tbody>
</table>

Read more at the Xfdesktop [http://docs.xfce.org/xfce/xfdesktop/4.11/start] official documentation.

Customizing your panel configuration

If you don’t like the default panel configuration, including the positioning or the applets installed by default, follow the steps below to customize the panel configuration:

... Right-click on the panel

... From the context menu, select Panel → Panel Preferences

... In the Display tab, you can control the panel’s size and positioning, including:

... Displaying the panel vertically along either side of the screen

... Moving the panel to the bottom or the right by unchecking Lock panel, grabbing the handle which appears at either side of the panel and dragging it

... Extending the panel across multiple monitors

... In the Appearance tab, you can pick another background for the panel and regulate its transparency

... In the Items tab, you can add, remove and rearrange panel applets and other items

... If you add a Launcher in the Items tab you can then edit the Launcher to run any application you have installed

Changing your desktop themes

There are three types of desktop themes:

--- xfwm themes - control how your window borders look. To change your xfwm theme, go to Settings Manager → Window Manager. In the Style tab, select a new theme to change the window borders appearance.

--- GTK themes - control how the content of the windows looks. To change your GTK theme, go to Settings Manager → Appearance. In the Style tab, select a new theme to change the window content appearance. The tool gtk-theme-config will also allow you to customize your window look.

--- Icon themes - control how your icons look. To change your icon theme, go to Settings Manager → Appearance. In the Icons tab, select a new theme to change the icon appearance. Note that not all icon sets will work well with dark panel/window backgrounds!

If the default selection of themes doesn’t satisfy you, you can download and install new themes. Some new themes can be installed from the Ubuntu repositories, and more can be found on the Internet, for example on Xfce-look.org [http://xfce-look.org/].
If you install new themes from the repositories, they should appear automatically in the Settings Manager. If you download a theme from any other site, you need to install the theme before it will appear in the Settings Manager. To do this, extract the theme package and copy them to:

... xfwm and GTK themes:

- ☐ /home/username/.themes/ (this user only)
- ☐ /usr/share/themes/ (all users)

... Icon themes:

- ☐ /home/username/.icons/ (this user only)
- ☐ /usr/share/icons/ (all users)

**Note**

If these directories do not exist, you should create them first. Copying themes or icons for all users will require administrative privileges.

**Disabling and modifying the desktop effects**

While Xubuntu doesn’t come with many desktop effects, the Xfce compositor is enabled by default. In the default Xubuntu configuration, the Xfce compositor is used to draw shadows for windows and to enable translucent panels. If you have a low-end GPU or you don’t like the desktop effects mentioned, you can turn off the compositor or change the settings by navigating to ☑ — Setting Manager — Window Manager Tweaks and in the Compositor tab either unticking Enable display compositing or modifying settings.
Chapter 5. Quick guide to default applications

Graphics

Ristretto is an image viewer designed to be very light on resources. More information can be found in the Ristretto online documentation [http://docs.xfce.org/apps/ristretto/start].

Simple Scan is an easy-to-use scan utility designed to do simple tasks like scanning to email or directly to PDF. Read more at the Simple Scan website [https://launchpad.net/simple-scan].

Internet

Firefox is a mature and stable web browser which can be extended with a wide variety of available add-ons. Read more on Firefox's online help [http://support.mozilla.org/en-US/home].

Thunderbird is a versatile mail client which can handle multiple email accounts and different identities simultaneously. Like Firefox, it can also be enhanced with add-ons to customize its appearance and extend its functionality. If you are migrating from another mail program, Thunderbird allows importing your emails and address books. In Thunderbird, navigate to Tools → Import to start the Import assistant. Read more on the Thunderbird Support page [https://support.mozillamessaging.com/en-US/home].

Pidgin is the default instant messaging client capable of handling MSN, XMPP (Google Talk, Facebook) and more. Read more from Using Pidgin [http://developer.pidgin.im/wiki/Using Pidgin] at the Pidgin online help.

Media

Parole is a simple media player that can play video and audio files. More information can be found in the Parole online documentation [http://docs.xfce.org/apps/parole/start].

Note

It will be necessary to install xubuntu-restricted-extras in order to play proprietary media formats like e.g. MP3.

PulseAudio Volume Control allows you to control the different sound sources available on your machine e.g. HDMI or other audio ports and where you hear the sound. Once open, the tabs available in pavucontrol are self-explanatory. However, if you have no sound - check specifically the Playback, Output Devices and Configuration tabs. More detailed information on PulseAudio and controlling it can be found at the PulseAudio website [http://www.freedesktop.org/wiki/Software/PulseAudio].

Xfburn is the chosen program for creating your CDs and DVDs.

To read more about media in Xubuntu, refer to Chapter 6, Media applications.
**Office**

**LibreOffice Writer** is a word processor with extensive WYSIWYG word processing capabilities. Read more at the LibreOffice Writer website [https://www.libreoffice.org/discover/writer/].

**LibreOffice Calc** is a spreadsheet editor with a number of unique features, including a system which automatically defines series of graphs, based on information available to the user. Read more at the LibreOffice Calc website [https://www.libreoffice.org/discover/calc/].

**Atril Document Viewer** is a lightweight and easy-to-navigate PDF reader with a compact selection of features, such as thumbnail browser, bookmarking, and toolbar editor function to tweak its user interface.

**Mate Calculator** is visually similar to a lot of hand-held calculators and has been designed to be used with either the mouse or the keyboard.

**Dictionary** provides an easy way to access a number of different dictionaries across the internet. Read more at the Xfce4 Dictionary online help [http://goodies.xfce.org/projects/applications/xfce4-dict].

**Orage** has been designed to be a simple but effective calendar application to keep track of your appointments and trigger alarms. Read more at the Orage website [http://www.kolumbus.fi/~w408237/orage/].

**System**

**Gigolo** is an easy way to connect to local and remote file systems. Read more at the Gigolo website [http://www.uvena.de/gigolo/].

**Engrampa** is an archive manager which allows to create and modify archives, view the contents of an archive and extract files from the archive.

**Task Manager** provides a graphical overview of running applications. More information can be found in the Task Manager online documentation [http://goodies.xfce.org/projects/applications/xfce4-taskmanager].
Chapter 6. Media applications

Music

Listening to music

You can use Parole Media Player to listen to music on your computer. Parole Media Player will open audio files when they are double-clicked. Alternatively, you can right click on audio files and select Open with Parole Media Player.

In order to play some popular audio formats like MP3, you will need to install some additional software. Unfortunately, this software cannot be provided by default in Xubuntu due to legal restrictions in some countries.

Caution

Read the section called “Restricted and non-free software,” before following the instructions below. There are some legal issues that you should be aware of.

Portable music players

Xubuntu will work with most portable audio players, including iPods. Normally, all you have to do is plug the player into your computer and then use File Manager to manually copy songs to and from the player.

Note

Newer iPods (6th generation and newer) will not work automatically with Xubuntu unless you have done an initial synchronization with iTunes first.

If you have a portable music player which can also display photos and videos, you may prefer to use Banshee, which is a music player with good support for such devices. iPod owners may also like to try specialized applications such as GPixPod, gtkpod, and ideviceinstaller for handling multimedia.

Movies, DVDs and videos

You can watch movies and video clips with the Parole Media Player.

Playing DVDs

In order to play DVDs you must install some additional software. Unfortunately, DVD support cannot be provided by default in Xubuntu due to legal restrictions in some countries.

Caution

Read the section called “Restricted and non-free software,” before following the instructions below. There are some legal issues that you should be aware of.

To be able to play DVDs, do the following:
Media applications

--- Install the `libdvdnav4`, `libdvdread4` and `gstreamer1.0-plugins-ugly` packages.

--- Insert a DVD into your drive. It should open automatically in the **Parole Media Player**.

--- If you would like to play encrypted DVDs, open ➔ **Accessories ➔ Terminal Emulator** and type the following into the **Terminal** followed by the ➔ Enter key: `sudo apt-get install libdvd-pkg`
Take note of the information provided in the terminal during installation, particularly with regard to upgrades to the package.

--- Once libdvd-pkg is finished run `sudo dpkg-reconfigure libdvd-pkg` The installation of libdvdcss2 will now complete.

Playing video

**Parole Media Player** supports most video types. If you try to play an unsupported video file, **Parole Media Player** may notify you of a missing plugin. You can then install this plugin by following the wizard. Afterwards, you may need to restart **Parole Media Player**.

If you are having difficulties getting a video to stream in your browser, **Parole Media Player** supports streaming most types of video. To open a video in **Parole Media Player**, right-click the video and select **Open with Parole Media Player**.

Restricted formats

Some video formats, such as Adobe Flash, QuickTime and Windows Media Video, are proprietary and so support for them cannot be included in Xubuntu by default. You must install some extra software to allow playback.

In order to play the most common proprietary formats in **Parole Media Player** or **Firefox**, install the `xubuntu-restricted-extras` package (see the section called “Restricted and non-free software,” for more information).

Burning CDs and DVDs

You can make your own CDs and DVDs by burning files onto a blank disc using the CD or DVD writer drive of your computer.

**Xfburn** is the default application in Xubuntu to complete these tasks. **Xfburn** allows you to to easily create audio CDs, burn CDs and DVDs with either plain data or disk images and prepare blank re-writable disks for a new burn.

In order to launch **Xfburn**, go to ➔ **Multimedia ➔ Xfburn**.

Once launched, you can insert a CD-R(W) or DVD-R(W) you wish to write to and then select the button corresponding to the action you wish to take (New Data Composition, Audio CD, etc.).
Chapter 7. Connecting to Internet and Networks

Xubuntu uses NetworkManager to manage wired, wireless, mobile broadband, VPN and DSL connections. NetworkManager also keeps passwords secure by utilizing the user's key ring to store passphrases.

NetworkManager is one of the little icons in the upper panel in the top right of your screen. When not connected, the icon shows two grayed out arrows pointing up and down. When you are connected, the icon is different depending on the network type in use.

Network connections

Connecting and disconnecting

NetworkManager will automatically use a wired network, if one is available.

To see all available connections, click the NetworkManager icon. To connect to a network, click the network name.

Note

If you are connecting to a wireless network for the first time, security details may be needed, a dialog box will open when required. In most cases, the security type will be detected automatically. If not, select the security type from the Wi-Fi Security drop-down box, enter the authentication details and press Connect.

To disconnect from a network, click the NetworkManager icon, and select Disconnect under the appropriate connection type. To disable (and re-enable) wired and/or wireless connections all together, click the NetworkManager icon, select Enable Networking and Enable Wi-Fi. These choices are toggles. Their enabled/disabled status is indicated by the presence/absence of a check mark.

Configuring connections

If you need to configure your connections, click the NetworkManager icon and select Edit. In the dialog, you will see expandable rows for each connection type. Select the appropriate network and press Edit or press Add to set up new networks.

Note

To be able to connect to certain networks you might need connection details which you will get from your network administrator or your Internet Service Provider.

Connection information

To see the connection information, click the NetworkManager icon and select Connection Information. Your active network connections will be displayed in the Active Connections dialog, each in a separate tab.
Sharing your connection to another computer

You can share your connection to another computer using an Ethernet cable. This can be carried out by clicking the NetworkManager icon, selecting Edit, and then adding a new wireless connection (or editing the existing one). In the connection properties window, select IPv4 Settings, and change Method to Shared to other computers from the drop-down list.

Dialup modems

Unfortunately, dialup modems are not supported by NetworkManager. To read about connecting with a dialup modem, please refer to the Dialup modem How-to [https://help.ubuntu.com/community/DialupModemHowto] on the Ubuntu community wiki.

Network troubleshooting

Before attempting any troubleshooting, ensure that the network connections are enabled:

... Click the NetworkManager icon in the notification area

... Check Enable Networking

... Check Enable Wi-Fi

If your network connection still doesn't work:

... For wired (Ethernet) connections, please see the section called “General troubleshooting”

... For wireless connections, please see both the section called “General troubleshooting,” and the section called “Wireless troubleshooting.”

... If your network connection problems are still not resolved, see the section called “Advanced troubleshooting.”

General troubleshooting

If your network connection is not working properly, there are a few tools that can be used to help diagnose the problem.

Get information about the current connection

To get information about your network connection and network devices, you have two options:

... Using NetworkManager

... Click on the NetworkManager icon

... Select Connection Information. If this is disabled, it is likely there is no active connection. Try using ifconfig to find out more.

... Each active connection will have its own tab where you can find relevant connection information
Connecting to Internet and Networks

... Using `ifconfig`

... Open a terminal (→ Accessories → Terminal Emulator), type the command `ifconfig` then press the `Enter` key.

... `ifconfig` will show you extensive information about your connection, including logical or connection name(s) (e.g. enp3s0) in the left column, IP address in the `inet addr` column and the MAC address for your device in the `HWaddr` column.

Check if a connection is working properly

A reliable method to check if a connection is working properly is to ping another computer on the network or the Internet.

To check if your computer is connected to the Internet, open a terminal (→ Accessories → Terminal Emulator), type the command `ping -c 3 www.xubuntu.org` then press the `Enter` key.

The computer will then attempt to contact www.xubuntu.org three times and display the results. The ping statistics display the number of packets transmitted, how many packets were received, the percentage of packet loss, and the total time spent.

... 0% packet loss indicates that your computer is connected to the Internet

... Greater than 0% but less than 100% packet loss indicates that your computer has a poor connection to the Internet or a poor wireless signal

... 100% packet loss indicates that your computer has a very bad connection, or is connected to an access point or router that is not connected to the Internet

If you get an error message that says "www.xubuntu.org can not be found" or "unknown host", then your computer is probably not connected to the Internet or is unable to reach a Domain Name System (DNS) server.

Wireless troubleshooting

This section covers some common problems faced with wireless support. There is much more information available in the Community Help Wiki [https://help.ubuntu.com/community/WifiDocs].

**Note**

Please note that the steps in this troubleshooting guide are designed to be carried out in the order shown, unless you are pointed to a different subsection.

Check that the device is turned on

Many wireless network devices can be turned on or off. Check for a hardware switch or a keyboard function key to turn the wireless device on.

If the device is turned on, continue to the next topic.
Check if the device is recognized

Open a terminal (-runner → Accessories → Terminal Emulator), type the command `sudo lshw -C network`, then press the Enter key. You will see some output, along with the words CLAIMED, UNCLAIMED, ENABLED or DISABLED.

... CLAIMED indicates that a driver is loaded but not functioning. Continue to the section called “Using Windows wireless drivers,"

... UNCLAIMED indicates that there is no driver loaded. Continue to the section called "Using Windows wireless drivers."

... ENABLED indicates that the driver is installed and working. Continue to the section the section called “Checking for a connection to the router."

... DISABLED indicates the driver is installed, but disabled. Continue to the section called “Check that the device is turned on.”

Using Windows wireless drivers

Xubuntu supports a system known as NDISWrapper. This allows you to use a Windows wireless device driver under Xubuntu. To start using NDISWrapper:

... Obtain the Windows driver for your network device and locate the file that ends with .inf

... Install the ndisgtk package

... Go to runner → runner Settings Manager → Windows Wireless Drivers

... Select Install new driver

... Choose the location of your Windows .inf file and click Install

... Click OK

Checking for a connection to the router

Open a terminal (runner → Accessories → Terminal Emulator), type the command `iwconfig` then press the Enter key.

If the ESSID for your router is displayed, there may be a problem with ACPI support. Boot Xubuntu with the pci=noacpi option.

Advanced troubleshooting

The following troubleshooting methods are a bit more technical. Please try these methods only if the above methods failed.

Checking IP assignment

Open a terminal (runner → Accessories → Terminal Emulator), type the command `ifconfig` then press the Enter key. If there is an IP address displayed, continue to the section called “Check Domain Name Servers (DNS)."
Connecting to Internet and Networks

From the terminal enter the following command, replacing `enp3s0` with the name of the connection shown in the output from the `ifconfig` command: `sudo dhclient enp3s0`

... If you receive a message that says bound to `xxx.xxx.xxx.xxx` continue to the section called “Check Domain Name Servers (DNS),”

... If not, reboot the system

Check Domain Name Servers (DNS)

Open a terminal (`→ Accessories → Terminal Emulator`), type the command `nmcli device show` then press the `Enter` key. Look for the entries under `IP4.DNS`

To check if the listed DNS works, open a terminal (`→ Accessories → Terminal Emulator`), type the command `dig xubuntu.org` then press the `Enter` key. If you see the word `NOERROR` in the header section of the output, your DNS is working.

If there are no DNS settings listed, contact your Internet Service Provider (ISP), and find out your primary and secondary domain name servers. Once you have this information, continue to the section called “Connecting and disconnecting,” and the section called “Configuring connections,” if needed.

Connecting to servers

To connect to various types of servers, you can use `→ System → Gigolo`. To connect to a server, follow the steps below:

... Go to Actions → Connect

... Select the appropriate Service type and insert connection information

... Click Connect; if you are attempting to connect to a server that requires you to log in, you will be prompted to enter a password

Upon successfully connecting to the server, an icon labeled with connection details will appear in the Gigolo window. To bookmark connections, right-click on a connection and select Create Bookmark. In the Edit Bookmarks dialog, you can name the bookmark and set other options, including the option to auto-connect. Once you are done, click OK to create the bookmark.

Tip

The Windows Share username should be in the format `DOMAIN\username`

Note

In order to connect to Samba networks (Windows shares) using the Thunar File Manager, you will need to have the package `gvfs-backends` installed.
Chapter 8. Printing and Scanning

Printing

Most printers are automatically supported by Xubuntu. The **Printer Configuration** application allows you to add printers, as well as modify their settings. You can also use this application to share the printer with other computers on a network, disable the printer or restart it.

Local printing

A local printer is one which is directly connected to your computer (as opposed to a network printer, discussed in the section called "Network printing"). To set up a new local printer, plug your printer into your computer and power it on. Most printers will be automatically detected and configured. Once detected, a printer icon will appear in the notification area and you should get a popup with the text **Printer is ready for printing**. If your printer was not detected, then you will need to follow these steps:

1. Obtain the model name of your printer
2. Ensure the printer is turned on
3. Go to **Settings Manager** → **Printers**
4. Click **Server** → **New** → **Printer**
5. Your printer should be automatically detected and displayed in the **Devices** window
6. Select your printer and click **Forward**
7. Your computer will search for and install drivers for your printer
8. You can enter a description and location for your printer
9. Press **Apply**
10. Your printer should be properly configured at this point and you will be prompted if you want to print a test page
11. If you press the **Print Test Page** button, a test page will print and you can verify if it printed correctly, or you can press **Cancel**. Either way, your printer is ready to print.

12. If you are still experiencing problems, try using the CUPS browser-based interface. It can be accessed at http://localhost:631/.

**Tip**

If your printer was not automatically detected, you can try to select the port and printer driver manually. Some printers need further setup. Search the OpenPrinting database [http://www.linuxfoundation.org/collaborate/workgroups/openprinting] or check the Ubuntu Wiki Printer page [https://wiki.ubuntu.com/HardwareSupportComponentsPrinters] for information on your printer.
Network printing

You can also configure your Xubuntu system to send print jobs to a remote print server. Remote printers are hosted somewhere on a network. To configure a remote printer:

... Obtain the model name of your printer

... Ensure the printer is turned on

--- Go to 🔄 → 🔄 Settings Manager → Printers

... Click Server → New → Printer

... Click on Network Printer in the Devices window

... If your printer is directly connected to a Windows machine on your network, choose Windows Printer via SAMBA. Otherwise, select the protocol your printer uses to communicate.

... Insert the details of the network printer and press Forward

... Select the printer manufacturer and then press Forward

... Select the printer model and driver then press Forward

... You can enter a description and location for your printer in the corresponding fields

... Press Apply

... Your printer is properly configured at this point and you will be prompted to print a test page, press Cancel or Print Test Page depending on your preference

Note

If you do not know the protocol or details of your network printer, you should consult your network administrator.

Tip

If you do not have a network printer, but want your printer to be shared to other computers on your network, click Server → Settings from the Printers dialog, check the box Publish shared printers connected to this system, and then press OK. Other computers running versions of Xubuntu later than 13.04 will automatically detect printers shared this way. Computers running Xubuntu versions prior to 13.10, or other Linux/Ubuntu-based systems, may need to enable a setting to show shared printers.

Scanning

Many scanners are automatically supported by Xubuntu, and should be easy to install and operate. This section will walk you through how to use your scanner and what to do if Xubuntu does not detect your scanner.
Does my scanner work in Xubuntu?

There are three ways to see if your scanner works in Xubuntu:

... Simply plug it in and try it! If it is a newer USB scanner, it is likely that it will just work.

... Check the list of supported scanners [https://wiki.ubuntu.com/HardwareSupportComponentsScanners] for Xubuntu

... Check the SANE project listing of support scanners [http://www.sane-project.org/sane-backends.html]. SANE is the software used by Xubuntu for most of its scanner support.

Using your scanner

To scan a document:

... Place what you want to scan on the scanner

... Go to → Graphics → Simple Scan

... Click the arrow to the right of the Scan button and choose the type of media you are scanning, Text or Photo

... Click the Scan button to begin your scan

The computer says "No scanners detected"

There are two reasons why you might get this message:

... Your scanner is not supported in Xubuntu. For example, most parallel port scanners and Lexmark All-in-One printer/scanner/faxes are not supported.

... The driver for your scanner is not being loaded automatically.

You may be able to get your scanner working by installing a driver or altering some configuration files. Please ask for advice on the Ubuntu forums [http://ubuntuforums.org/] or on AskUbuntu [http://askubuntu.com/]..

Note

To get some scanners working, you may need to plug in the scanner after the computer has booted.

Manually installing a scanner

There are some scanners that have less-than-complete drivers from the SANE project. They can sometimes be used, but not all the features may work.

... Install the sudo libsane-extras package

... Run pkexec mousepad /etc/sane.d/dll.conf at the command line to open the SANE driver file for editing
... Enable the correct driver for your scanner by removing the # from in front of the name of the driver. You may need to search the web to find out which driver is the right one.

... Save the file and open Simple Scan. If all goes well, your scanner will now work.
Chapter 9. Managing installed applications

In Xubuntu, you don't need to download and install packages separately. Instead, repositories contain sets of packages. These repositories are then accessed with package managers in order to add, remove or update the packages.

Xubuntu comes with two package managers installed:

… Gnome Software, a simple graphical user interface to install new software.

… apt-get, a command-line tool that can be used for advanced package management. For more information on apt-get, see the Debian apt manual [http://www.debian.org/doc/user-manuals#apt-howto].

| Note |
| You will need administrative access to add and remove software.

| Caution |
| In most cases you can only use one package manager at a time. If you start another package manager while one is already open, you may receive an error message. In this case it is likely the second package manager will not function correctly.

Using Gnome Software

You can launch Gnome Software from Software.

Installing new software

… Search for an application or select a category to find an application you want to install

… From the application page, click Install

… You will be asked to enter your password; once you do that, installation will begin

… A shortcut to your application will added to the Applications menu

| Note |
| To be able to install new software from the repositories, you need to be connected to the Internet. See Chapter 10, Offline Package Management for information on using apt-offline.

Removing software

… Click Installed on the top panel
Managing installed applications

Find the application that you want to remove by using the search box or looking through the installed applications.

Select the application and click **Remove**.

You may be asked to enter your password; once you do that, the application will be removed.

**Caution**

Some applications depend on others being installed in order to work properly. If you try to remove an application which is needed by another application, both of them will be removed. You will be asked to confirm that this is what you want to happen before the applications are removed.

**Note**

**Gnome Software** does not remove dependencies installed with a package. To remove any dependencies no longer needed, run `sudo apt-get autoremove` in a terminal. Before agreeing to the command continuing, check that the packages being marked for removal are as expected.

Additional software repositories

**Enabling more repositories**

It is possible to add extra repositories, such as those provided by third parties. To enable more software repositories:

Open 

- Open **Settings Manager** → **Software & Updates** or **Software** → **Software & Updates** and go to the **Other Software** tab.

Press **Add...** to add a new repository.

Enter the APT line for the extra repository. This is available from the website of the repository in the majority of cases and it should look something like the following: **deb http://ftp.debian.org etch main**

Press **Add Source** and then click **Close** to save your changes.

You will be notified that the information about available software is out-of-date. Press **Reload**.

Most software repositories use a GPG key to digitally sign the files they provide, which makes it easy to check that the files have not been tampered with since their creation. In order for apt to be able to check this, you need the public key that corresponds to the signatures. The key should be available for download on the repository’s website. Once you have downloaded the GPG key, import the key by selecting the **Authentication** tab, clicking on **Import Key File**, and then selecting the GPG key to be imported.

**Caution**

Be careful when installing software from third-party repositories. It may not have been officially tested with Xubuntu and could cause your system to break.
Managing installed applications

Restricted and non-free software

Most of the software available for Xubuntu is free, open-source software. This software is free for anyone to install and use, and people can modify the software and redistribute it if they like. Xubuntu is built from this type of software.

*Non-free software* is software that is not freely redistributable or modifiable. This makes it difficult for the Xubuntu developers to improve the software and correct problems, so it is normally recommended that you use free software [http://www.ubuntu.com/project/about-ubuntu/our-philosophy] instead.

*Restricted software* is software that has restrictions on its use, preventing it from being classed as free software. Non-free software is a type of restricted software, where the restrictions are due to the software having a non-free license. Other reasons for software being classed as restricted include legal issues (use of some types of software is illegal in some countries) and patent issues (some software requires a patent license to be used legally).

In some cases, restricted software is the only option. Such cases include software for the playback of certain audio and video formats, some fonts and certain video card drivers.

You should be warned by the package manager when you try to install restricted software. If the restricted software cannot be used legally in your country then there is little you can do; you should not install the software. If the software is restricted simply because it is non-free, you may choose to use it (for example, in the case of graphics card drivers). Be aware that most restricted software is not supported in Xubuntu and problems with such software often cannot be corrected by Xubuntu developers.

**Warning**

Sometimes it is difficult to determine why a particular software package is restricted. If this is the case, seek advice on the Ubuntu Forums [http://ubuntuforums.org/]. If you are still unable to determine why a package is restricted, err on the side of caution and do not install it; it may be illegal to use it in your country.

Installing packages without an Internet connection

Adding discs as software sources

To add a disc as a software source for your system:

... Insert a disc which contains packages; e.g., the Xubuntu installation disc which comes with a limited selection of packages

... Open ➔ ➔ *Settings Manager ➔ Software & Updates* and go to the *Other Software* tab

... Press the *Add Volume...* button; you will be prompted for your password

After adding the disc to the software sources, you will be able to install packages from the disc.
Managing installed applications

Helpful application

If you have less than optimal Internet access, **apt-offline** allows you to use another computer with better access to download packages and check for package updates like security fixes. All you need is time, patience, and a portable USB storage device. A usage example to learn more about this can be found in Chapter 10, *Offline Package Management*.

Changing update frequency and behavior

You can change the frequency of the check and the way in which updates are handled. When **Software Updater** runs and presents you with its dialog, there is a **Settings** button at the bottom. Pressing this will open the **Software Sources** dialog at the **Updates** tab. Alternatively, you can access the settings dialog by going to ☰ → 🗑️ **Settings Manager** → **Software & Updates** and opening the **Updates** tab.

The following settings can be changed from this dialog:

**Update Sources**

... *Important security updates* - Updates that fix critical security flaws are made available through this source. It is recommended that all users leave this source enabled (it should be enabled by default).

... *Recommended updates* - Updates that fix serious software problems (which are not security flaws) are made available through this source. Most users will want to leave this source enabled as common and annoying problems are often fixed with these updates.

**Caution**

The following updates should be used with some caution.

... *Pre-released updates* - Updates that are currently being tested before being released to everyone are provided through this update source. If you would like to help test new updates (and get fixes for problems more quickly), enable this source. Be aware that these updates may not yet be well tested; it is not recommended that you enable this source unless you are prepared to experience occasional problems.

... *Unsupported updates* - When new versions of popular software are released they are sometimes "backported" to an older version of Xubuntu so that users can benefit from new features and fixes for problems. These backports are unsupported, may cause problems when installed and should only be used by people who are in a real need of a new version of a software package that they know has been backported.

**Notifications of new Xubuntu versions**

This section of the **Software Updater** deals with the way you wish future versions to be given to you. You have three options:

... *For any new version* - You will get notifications of all new releases, once in 6 months

... *For long-term support versions* - You will get notifications of new Long-term Support (LTS) releases, once in 2 years

29
Managing installed applications

• Never - You will not get notifications of new releases

<table>
<thead>
<tr>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>Opting in for Long-term Support (LTS) notifications is usually the recommended option, especially if you are running Xubuntu on a production machine and/or need maximum stability.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Warning</th>
</tr>
</thead>
<tbody>
<tr>
<td>It's not recommended to use the <em>Never</em> setting. This will leave you with an unsupported system, unless you manually remember to upgrade often enough. Additionally you will be missing out on bug fixes, updates for potential security problems and hardware support improvements. See Chapter 2, <em>Migrating and Upgrading</em> for more information on upgrading Xubuntu and release support lengths.</td>
</tr>
</tbody>
</table>

Other options

Package updates can be scheduled from the desktop and you can change how and when the system updates itself.

• *Frequency of check* - Allows you to schedule when to check for updates

• *Checking and installing updates automatically* - Allows you to define if the system downloads and install updates without confirmation or downloads all updates in the background but waits for you to manually install them

• *Displaying notifications about security updates* - Allows you to define when will the system notify you about available security updates
Chapter 10. Offline Package Management

The tool `apt-offline` is available to help keep your computer up to date even if it cannot be kept connected by using a second internet connected computer, this other computer can run Xubuntu, another flavor of Ubuntu, or Debian. A graphical interface is available via `apt-offline-gui`. This document deals with the command line variant.

Throughout this chapter directions to use a directory on a USB flashdrive are given, the naming and path to this directory is for you to decide beforehand.

**Warning**

A few specific packages are not built to handle the disconnected environment, due to them running download scripts during the installation or upgrade process. Some packages that routinely exhibit this behavior are `flashplugin-installer`, `nautilus-dropbox`, and `ttf-mscorefonts-installer`. There is no workaround for installation packages that themselves make downloads.

**Note**

You will want to avoid the use of the `-y` flag when upgrading so that you get a last chance to look through your upgrades to see if any problems mentioned above show up.

**Note**

During the use of `apt-offline` some errors in red text may show up about being unable to download files relative to translations, these can be safely ignored.

### Updating Repositories

After plugging in a USB flash drive and opening a terminal, you can use `apt-offline` to generate a request to update what your computer knows about software repositories. This allows your computer to see if there are bug fixes, security updates or new software available for your computer.

From your disconnected computer run: `apt-offline set --update apt-offline.sig`

Once done, copy `apt-offline.sig` to your USB flash drive and take it to another computer. With `apt-offline` on that computer, use that file to download what your disconnected computer needs to update itself. Navigate to the directory on the flash drive containing `apt-offline.sig`, enter `apt-offline get --bundle bundle.zip apt-offline.sig`. When complete remove the USB flash drive and take it back to the disconnected computer.

At the disconnected computer, re-insert the USB flash drive. Navigate to the directory on the flash drive containing the two files, then enter: `sudo apt-offline install bundle.zip`. Once the command completes your repositories will be updated.
Installing a Package

You can use apt-offline to download a package to install. This action can also be combined with updating the software repositories. In a disconnected environment, using opportunities to connect efficiently is key.

In this example, we assume you want to install a new program package. Throughout this we'll refer to this as PACKAGENAME though in normal use you will want to enter just the package name. Fairly frequently, installing a package will require you to install dependencies. apt-offline handles the dependency resolution for you. To start this process open a terminal window, plug in a USB flash drive, and navigate to the directory. From that directory run  

```
sudo apt-offline set --install-packages $PACKAGENAME --update apt-offline.sig
```

start the process. When complete, copy apt-offline.sig to your USB flash drive and take it to another computer. With apt-offline on that computer, use that file to download what your disconnected computer needs to update and install PACKAGENAME. Navigate to the directory on the flash drive containing apt-offline.sig, run  

```
sudo apt-offline get --bundle bundle.zip apt-offline.sig
```

The output will show an attempt to download repository updates as well as PACKAGENAME and any dependencies your system requires. Remove the USB flash drive when complete and take it back to the disconnected computer.

At the disconnected computer, insert the USB flash drive. Navigate to the directory on the flash drive containing the two files then enter:  

```
sudo apt-offline install bundle.zip
```

Once it completes your repositories will be updated. Once that completes, you can then install PACKAGENAME by then entering:  

```
sudo apt-get install PACKAGENAME
```

Upgrading Your System

Upgrading packages requires 2 stages: updating repositories and then the download and upgrade as required.

First update your repositories following the instructions in the section called "Updating Repositories."

Clear the directory on USB flash drive that you have used previously. In a fresh terminal window, navigate to the directory on the USB flash drive you intend to work from. Since we never want to lose the opportunity to refresh the disconnected machine's view of the repositories, we can build the command to not only look for upgrade packages but also to update repositories. Enter  

```
apt-offline set --update --upgrade apt-offline.sig
```

Once done, copy apt-offline.sig to your USB flash drive and take it to another computer. With apt-offline on that computer, you use that file to download what your disconnected computer needs to upgrade itself. Navigate to the directory on the flash drive containing apt-offline.sig, run  

```
sudo apt-offline get --bundle bundle.zip apt-offline.sig
```

The output will show an attempt to download repository updates as well as any upgrades and dependencies required by your system. Once done, remove the USB flash drive and take it back to the disconnected computer.

At the disconnected computer, insert the USB flash drive navigate to the directory on the flash drive containing the two files, enter  

```
sudo apt-offline install bundle.zip
```

Once it completes your repositories will be updated, you can then install the upgrades by entering:  

```
sudo apt-get upgrade
```


Chapter 11. Keeping your computer and personal information safe

Keeping your computer and personal information safe from security threats is one of the most important aspects of computing today. This guide aims to help you achieve a higher level of security. Pay particular attention to the following subsections:

• the section called “Keep your software up to date”
• the section called “Use strong and unique passwords for important accounts”
• the section called “Do not run scripts or install applications from unknown sources”
• the section called “Keep your browser clean for sensitive activities”
• the section called “Remember email security”

Keep your software up to date

Security updates are very important. They are the best defense you have against the people who want to harm your computer, and you should install them immediately. When a security update is released, hackers already know how to abuse computers that are not up-to-date. In the worst case scenario, they are searching for victims to hack with automated programs in under a few hours.

Automatic security updates are enabled by default in Xubuntu. If you want to change the settings for the automatic updates, go to the Updates tab under Settings Manager → Software & Updates and change the settings to your liking.

<table>
<thead>
<tr>
<th>Warning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Disabling automatic updates lowers the security level of your computer. When the automatic updates are turned off, it is essential to remember to manually upgrade often.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Tip</th>
</tr>
</thead>
<tbody>
<tr>
<td>If you use an Internet connection with limited bandwidth and do not want to use automatic updates, remember to update every time you have access to an unlimited connection.</td>
</tr>
</tbody>
</table>

Passwords

<table>
<thead>
<tr>
<th>Warning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Official companies will not ask you for your password. If you are asked for your password, delete any e-mail asking for such. If you are on the telephone, hang up and call someone you know to ensure that the connection to those asking is lost.</td>
</tr>
</tbody>
</table>
Use strong and unique passwords for important accounts

Using strong and unique passwords for important and sensitive accounts helps prevent unauthorized access to your personal information, identity theft and direct financial losses. Consider the following scenario:

1. Alice uses identical passwords for mytrustedbank.com and insecureblog.com
2. insecureblog is hacked and Alice’s information and password are stolen
3. Hackers can now access Alice’s bank account and steal her money

Password reuse can turn into a disaster. You should pay attention to use unique and strong passwords for the following services:

...Email accounts. Email accounts can be used to reset all your other passwords via the “Forgotten password,” links found on all websites.

...Key stores and password managers. It is worth having a good password for those services, since they allow you to avoid typing many other passwords!

...Accounts related to banking, including PayPal and other payment sites. If someone can access these, they can steal your money.

What is a strong password?

The strength of a password depends on how hard it is for an attacker to guess it. Attackers use special programs that can make millions of guesses per second, so weak passwords don’t stand a chance.

Some passwords (like monkey, password, test, 123456) are extremely common. If you use those common passwords, your accounts will be hacked easily. However, adding capital letters, numbers or symbols is often not enough to turn a weak password into a strong one. This is because people reliably pick the same additional symbols and numbers (for instance, monkey1 is more common than mo5nkey, and also more common than monkey hoover).

It is better to choose a longer secret, such as a pass phrase (for example correct horse stable battery), than a secret that is both hard to remember and easy to crack. Consider using a series of common words which you can easily remember. Do not pick words that people around you would naturally associate with you (for instance, you should not pick poker related words if you play poker every day).

How to reuse passwords safely?

While using the same password for multiple accounts is not encouraged, everybody ends up doing this, even security experts. However, many commonly used websites get compromised by hackers every year. Some of them might even purposefully sell their users’ passwords to third-parties. There is no definitive agreement among security researchers on how to reduce the risk of reusing passwords, but you should consider the following:

...Separate your professional password from your personal passwords.
Keeping your computer and personal information safe

- Avoid mixing passwords between websites where attackers can damage your reputation and low-value websites.
- Use a password you're willing to lose for sites you do not trust.
- Do not "waste" passwords on websites you connect to once a year. Make up a random password and use the "forgotten password" feature next time.

When to change your password?

You don't need to change your passwords every other day. In many cases, if an attacker can steal your password, they will be able to steal it again in the future.

If you do need to change your password, you must pick one that is actually different from the previous one. For example, monkey5 is not an acceptable substitute for monkey4, and it will be easily guessed by an attacker who already stole your previous password!

How to change your login password

To change your password, follow the steps below:

- Open Settings Manager → Users and Groups
- Click on your username on the list
- Click Change... next to the Password label
- First enter your Current password
- Now you can either
  - Generate a random password by selecting Generate random password and pressing Generate
  - Choose your new password yourself by typing the new password to the New password and Confirmation fields
- Finally, click OK to confirm the password change

Caution

While it is possible to make Xubuntu log in automatically on boot within the user dialog, automatic login is highly discouraged because it provides less security for your system. Please turn on automatic login on only if you can trust everybody that has access to the computer.

Watch out for stolen passwords occasionally

Websites like haveibeenpwned.com [https://haveibeenpwned.com/] can tell you if your email address or username appears amongst databases of stolen passwords. It is a good idea to check it every other month. Besides, you may occasionally hear about a service you use in the news, or get an email from a service provider informing you that they have been hacked. When you are confident that a password has been compromised, you should:
Keeping your computer and personal information safe

1. Identify all the services where you used that password
2. Change your password on all those services
3. Verify the recent activity on the concerned accounts (watch out for money transfers; also, email services often keep a log of your recent connections with IP addresses and locations)

**Warning**

Never reveal your password to a third-party website. The website above is OK to use because it asks for an email address, which is relatively public information. It does not ask for a password. Websites that ask for your password will most likely misuse it.

**What about password managers?**

Password managers are a very convenient way of using many unique passwords without having to remember them all!

**Tip**

There are several password managers available in the repositories, including KeePassX and PaSaffe.

Some password managers, like KeePassX can synchronise your passwords across devices, including Windows or OS X computers. You should be aware of a few limitations, if you decide to use a password manager:

... Online password managers can be hacked too. Do not store your email or bank passwords in a password manager.

... Use a memorable password to unlock your password manager! If you lose that password, you could end up losing access to all your accounts (another good reason not to store emails in your password manager).

... Proprietary password managers should not be trusted. Nobody knows what they do with your passwords.

... You may need to use some accounts from your friends or family’s devices. For those accounts, you can tell your password manager to use a specific and memorable password instead of a random password.

If you keep the above advice in mind, password managers can be a great way to stay more secure, more easily!

**Tips for good online security**

**Do not run scripts or install applications from unknown sources**

... Install applications from the repository whenever possible.
Keeping your computer and personal information safe

When running a script found on a troubleshooting or support website or given to you on IRC, take a moment to look at it, or ask a third-party to confirm what the script does. Be especially wary of scripts that require root access, as they could compromise other users’ accounts.

Keep your browser clean for sensitive activities

Web browser extensions are a popular mechanism among hackers for harming users. They are especially relevant to Linux, since they are compatible with all platforms. Malicious extensions could steal your passwords, monitor your activity online for advertising, abuse your social media accounts or steal your money.

You can take measures to limit the risks you expose yourself to:

Never install an extension that is not distributed by your browser vendor

On Firefox, use a separate user profile for sensitive activities like banking and e-shopping. Firefox user profiles do not share extensions (see Use the Profile Manager to create and remove Firefox profiles [https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles]).

On Chrome and other browsers, use the Incognito mode for sensitive activities like banking and e-shopping. Incognito mode disables extensions.

Remember email security

Do not open email attachments from people that you don’t know, or if you think the content of the email is incoherent or suspicious (for example invoices coming from people you have never heard of).

Do not reply to spam. This will inform spammers that your email address is active, and it will incite them to send you more spam.

Consider firewalls if your computer hosts Internet services

If you run public facing Internet services, or are not on a NAT, you should consider using a firewall. Most home users are not concerned by this measure.

Understand that firewalls are not very useful in their default settings. You should consider what you want to achieve and configure the firewall accordingly. Firewalls can protect you against denial of service attacks, limit access to a service to specific IP addresses or inspect and reject suspicious packets. However, they cannot protect you against unknown or emerging threats, and they do not replace the need to install security updates.

Back up on a regular basis

A problem that you may occasionally encounter is the unexpected loss of some of your work and settings for one reason or another. The causes of such data loss are many and varied; they could be anything from a power failure to accidentally deleting a file. It is highly recommended that you make regular backup copies of your important files so that, if you do encounter a problem, you will not have lost those files.

It is wise to store backup copies of files separately from your computer; that is, you should make use of some form of file storage which is not permanently attached to your computer. Options include but
Keeping your computer and personal information safe are not limited to writable CDs and DVDs, external hard disks, USB disks and other computers on the network.

A simple way of backing up your files is to manually copy them to a safe location (see above) by using the **File Browser** as well as the **Archive Manager** which lets you compress files and pack them together. Alternatively, you can use a dedicated backup application.

General advice on how to keep good backups:

... Back up on a regular basis

... Always test your backups after you make them to ensure that they have been made correctly

... Label your backups clearly and keep them in a safe place

**Tip**

There are numerous dedicated backup applications available in the repositories, including **Dejà Dup** and **luckyBackup**.

**Tip**

If you use online backup services like Dropbox, it is a good idea to first encrypt your documents and upload an encrypted archive. This will prevent the online services staff from accessing your documents.

**Tip**

Backups can also be an effective protection against ransomware, which encrypts your data and will only decrypt it if you pay the developers. To keep clean from ransomware, avoid installing applications from unknown sources. For more information, see the section called "Do not run scripts or install applications from unknown sources."

### Consider encryption

Full disk encryption is a good measure to protect your computers content should it get stolen. You should consider it if, for instance, your job involves valuable Intellectual Property or executive responsibilities. Remember that full disk encryption will not protect you if you do not shutdown your computer when you are not using it.

**Tip**

The easiest way to enable full disk encryption is to do it during the installation.

**Tip**

You can also create encrypted volumes using dedicated software, for example LUKS. Encrypted volumes can contain arbitrary data of any length. You can mount them like you would insert a USB key when you need to access their content, and keep them closed the rest of the time. Describing the process to do this is outside the scope of this documentation, but there are numerous tutorials online.
Keeping your computer and personal information safe

Using your computer in a shared environment

Do not use shared accounts

When Xubuntu is installed, it is set up for a single person to use. If more than one person will use the computer, it is best for each person to have their own user account. To read more about adding users, refer to the section called “Users and groups.”

Lock your screen while away

Locking your screen prevents other people from accessing your computer while you are away from it. All of your applications and work remain open while the screen is locked.

To lock the screen, press $\text{Ctrl}+\text{Alt}+\text{Delete}$ or click $\rightarrow \text{Lock Screen}$.

To unlock the screen, move the mouse or press a key. Then, type your password and either press the $\text{Enter}$ key or click the $\text{Unlock}$ button.

If more than one person has a user account on your computer and the screen is locked, other users can press the triangle button to the right of the user name, select their name from the list and enter their password to use the computer, even while the screen is locked. They will be unable to access your currently open work and you will be able to switch back to your locked session when they have finished using the computer.
Chapter 12. Hardware devices

Your computer consists of a number of connected devices collectively known as computer hardware.

Xubuntu normally configures your hardware automatically, but there may be occasions when you need to make changes to hardware settings yourself. This section provides information on tools which can be used to configure your hardware.

Restricted drivers

Why are some drivers restricted?

Restricted drivers are drivers for your hardware that are not freely available or open source.

Most of the devices (hardware) attached to your computer should function properly in Xubuntu. These devices are likely to have unrestricted drivers, which means that the drivers can be modified by the Xubuntu developers and problems with them can be fixed.

Some hardware does not have unrestricted drivers, usually because the hardware manufacturer has not released details of their hardware that would make it possible to create such a driver. These devices may have limited functionality or may not work at all.

Enabling restricted drivers

If a restricted driver is available for a certain device, it can be installed in order to allow your device to function properly, or to add new features. For example, installing a restricted driver for certain graphics cards may allow you to use more advanced visual effects.

Some computers may not have any devices that can use restricted drivers, either because all of the devices are fully supported by unrestricted drivers or because no restricted drivers are yet available for the device.

If any drivers are available for your hardware they will be installable from the Software and Updates application:

... Go to Settings → Additional Drivers

... You will, if necessary, be prompted to enter the administration password.

... You may be prompted to reboot to finish installation.

Disabling restricted drivers

If a restricted driver is causing problems, or you would just like to turn it off, follow the procedure below:

... Go to Settings → Additional Drivers

... Find the driver that you would like to disable and press the Deactivate button.

... You will be prompted to enter your password.
Hardware devices

**Note**
You may need to restart your computer to finish disabling the driver.

## Disks and partitions

### Checking how much disk space is available

A simple way to check available disk space is to launch *Thunar*. There are several ways to do this:

- Go to ➔ **Accessories** ➔ **File Manager**

- Double-click on the *File System or Home* icon on your Desktop

- Click the home folder on the Launcher Panel

The status bar at the bottom of the window shows the free space for the current drive or disk. If you have more than one drive mounted or connected, you can click on them in the side pane and you will then see displayed the free space for that disk.

### How can I free up disk space?

There are several simple ways of making more disk space available:

- Empty your trash by right-clicking the *Trash* icon on the Desktop or the Launcher Panel and selecting *Empty Trash*.

- Remove software packages that you no longer use. See the section called “Removing software,” for information on removing packages.

- Delete files that you no longer need. You can install the *GNOME Disk Usage Analyzer* from Gnome Software to find which files are taking up the most space.

**Warning**
Be careful not to delete files that you still need!

### Partitioning a Device

You can use *GParted (GNOME Partition Editor)* to partition storage devices. Install *GParted* from Gnome Software and then go to ➔ **Settings Manager** ➔ *GParted* to start the partition editor.

**Warning**
Be careful when altering disk partitions, as it is possible to lose your data if you delete or change the wrong partition.

**Warning**
Altering disk partitions can take some time. Do not assume that GParted has hung or crashed while it is working.
Note

If it is necessary to unmount the installed system to proceed with changes you wish to make, you will have to work from a live CD/USB to do so.

Freeing space for a new partition

To create a new partition inside an already partitioned device, you must first resize an existing partition. If you already have free space, skip to the section called "Creating a new partition," section. Otherwise, follow the instructions below:

... Select the device to partition from the drop-down list at the top-right of the main window

... A list of partitions will appear in the main window. Select the partition you want to resize and from the menu, choose Partition → Unmount

... To resize the partition choose Partition → Resize/Move. The Resize/Move dialog will be shown. You can use the Free Space Following (MiB) box to choose how much space to free after this partition, or Free Space Preceding (MiB) to free space before this partition. Alternatively you can use the slider to adjust the partition size.

... Click Resize/Move

... To apply the changes, click Edit → Apply All Operations

Creating a new partition

To create a new partition:

... Select the device to partition from the drop-down list at the top-right of the main window

... A list of partitions will appear. Select the one called unallocated, right-click on it and click New

... From the File system: pick list, choose the desired type of filesystem to use.

... If desired, enter a description for the partition in the Label: field.

... Click the Add button.

... To apply the changes, click Edit → Apply All Operations

Formatting a partition

To format a partition, do the following:

... Select the device to partition from the drop-down list at the top-right of the main window

... A list of partitions will appear. Select the desired partition and choose Partition → Unmount.

... Select the partition you want to format and choose Partition → Format to and select from the list the type of filesystem to format the partition to

... To apply the changes, click Edit → Apply All Operations
Mounting and unmounting devices

When you connect a removable storage device to your computer, it must be mounted by the operating system so that you are able to access the files on the device.

To find out how to mount and unmount storage devices manually and/or automatically, see the Ubuntu community wiki page for the mount command [https://help.ubuntu.com/community/Mount].

When you copy files to a removable storage device, they are not always written to the device immediately. Instead, they are often stored in a queue so that they can all be transferred across to the device at the same time (for reasons of efficiency). Running the command `sync` can force pending data to be written to removable storage devices. If you disconnect the device before all of the files have been transferred, you could lose the files. To prevent this, you must always unmount a removable device before disconnecting it.

Laptops

Power management settings

You may wish to change the power management settings of your laptop in order to help extend its battery life and save energy.

... Go to ➔ ➔ Settings Manager ➔ Power Manager

... Change settings as appropriate

... Changes are applied instantly

Tip

When your laptop is running on battery, one of the biggest drains on power is the display. Turning the brightness of the display down could improve battery life significantly; many laptops allow you to do this by pressing `Fn+F7` (or other marked key) several times.

Touchpads

Most laptop computers come with a touchpad, which is used to control the mouse pointer. There are many ways of changing the way that the touchpad behaves; the most basic touchpad settings can be configured in the following way:

... Go to ➔ ➔ Settings Manager ➔ Mouse and Touchpad

... From the Device: field pick list, select the touchpad.

... Here you can change the touchpad settings to your liking. Changes should take effect immediately.

Note

Some touchpads may be detected as normal mouse devices, even though they are actually touchpads. In this case, the Touchpad device will not be available in the mouse preferences.
See the Touchpads [https://help.ubuntu.com/community/SynapticsTouchpad] page in the Ubuntu community wiki for more information on touchpads.

**SUSPENDING AND HIBERNATING**

In order to save power, you can put your computer into one of a number of power-saving modes when you are not using it:

... Suspending a computer is like putting the computer to sleep. The computer will still be turned on and all of your work will be left open, but it will use much less power. You can wake the computer by pressing a key or clicking the mouse.

... Hibernating is turning the computer off completely while saving the current state of the computer (such as keeping all of your open documents). When you turn the computer back on after hibernating, all of your work should be restored as it was before hibernation. No power is used when the computer is hibernating.

... Resuming is bringing the computer out of a power saving mode and back into normal operation. You can resume the computer from being suspended by pressing a keyboard button or by clicking the mouse. You can resume from hibernation by pressing the power button on your computer.

**Note**

Note that hibernate is disabled by default in Xubuntu and does not appear as an option in any menus. For a command line workaround, see the section called “Enabling hibernation.”

You can manually put your computer into a power-saving mode by pressing **Log Out** and then pressing the appropriate button.

**Note**

Some computers may have problems going into certain power-saving modes. The best way of checking if your computer can handle a power-saving mode is to try to switch to that mode and see if it behaves as you expected. Always make sure you save important documents before suspending or hibernating.

**MY COMPUTER DOESN'T SUSPEND OR HIBERNATE CORRECTLY**

Some computers are unable to suspend or hibernate correctly with Xubuntu. If this is the case for your computer, you may notice some of the following symptoms:

... The computer does not turn off after you click to hibernate it.

... When you turn the computer on after hibernating it, your previously open programs are not restored.

... The computer will not wake up after you have suspended it.

... Certain programs or hardware devices stop working correctly after resuming from hibernation or waking-up from being suspended.
Hardware devices

If you suffer from any of these problems, you should report a bug to Launchpad [http://launchpad.net/]. The problems will hopefully be fixed in a subsequent version of Xubuntu. If your hardware does not work properly after suspending or hibernating your computer, restart your computer and it should return to normal. If a program does not work properly, try closing the program and then starting it again.

**Warning**

Make sure that you save all of your open documents before testing for suspend and hibernate problems.

**Enabling hibernation**

To enable and use hibernation with Xubuntu, do the following:

... Install the **pm-utils** package from **Gnome Software**.

... From the command line, enter: `sudo pm-hibernate`.

... Enter your password.

... To resume from hibernation, press the power button.

**I get strange patterns on the screen when I hibernate my computer**

Your screen may show a black and white pattern just after you click to hibernate your computer. This is usually nothing to worry about and is just how the graphics cards of some computers respond to the initial stages of the hibernation process. If the computer displays the pattern for a prolonged period of time without turning itself off then you may have a problem with hibernation. See the section called “My computer doesn't suspend or hibernate correctly,” for more information.

**Mice and keyboards**

When you install Xubuntu, you are given the option of selecting your keyboard type and language. During the installation, your pointing devices should be automatically detected and configured. If you want or need to change the settings of any of these devices after installation, you can do so by going to **Settings Manager → Mouse and Touchpad** or **Settings Manager → Keyboard**.

Options for mice and touchpads include:

... **Button orientation**

... **Pointer speed and sensitivity**

... **Double-click sensitivity**

... **Cursor theme**

Some of the options for configuring your keyboard include:

... **State of the Num Lock key on startup**
Hardware devices

... Key repeat speed and delay

... Cursor blinking speed

... Application keyboard shortcuts

... Keyboard layout and language

**Tip**

If you are using a mouse on a laptop that also has a touchpad, you can change the behavior of each of them individually by selecting the appropriate device from the Device: pick list on the Devices tab page.
Chapter 13. Administrative tasks

For security reasons, administrative tasks in Xubuntu can only be performed by users with special administrative privileges. The first user account created during installation will, by default, be able to perform administrative tasks.

When you run an application that requires administrative privileges, you will be asked to enter your user password. This helps to protect your system from malicious files and lessens the chances that you will accidentally select options which may change the way your system works.

Each time you type your password, the system remembers it for 15 minutes so that you do not have to type it again.

<table>
<thead>
<tr>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>Users must be a member of the 'sudo' group in order to carry out administrative operations. Information on how to change groups can be found below.</td>
</tr>
</tbody>
</table>

Users and groups

When Xubuntu is installed, only one user account is created. If multiple users use the computer, it is highly encouraged to create separate user accounts for everybody. This allows users to have their individual settings, files and access rights.

To modify the users or groups on your system, navigate to Settings Manager → Users and Groups.

<table>
<thead>
<tr>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>You need administrative rights to make changes to users and groups.</td>
</tr>
</tbody>
</table>

Managing users

To add a new user:

... Click the Add button

... Enter you password

... Fill in the Name and Username

... Click the OK button

If you want to give a user administrative rights to the system:

... Select the user whose account type you want to change and press the Change... button

... Enter your password if prompted to do so

... Select the Administrator option (or select Desktop User to revert)

... Press OK to apply the selected changes
Administrative tasks

Tip
For more fine-grained access control, click the Advanced Settings button in the User Settings dialog, enter your password, click the User Privileges tab and from there select or deselect wanted capabilities.

To remove a user from the system, select the user you want to delete and click the Delete button.

Managing groups

To add a new group:

... Click the Manage Groups button

... Click the Add button

... Enter your password

... Choose a name for the new group and, if you want, change the default value for the Group ID

... At this time, you have the option of selecting Group Members from the list

... Click the OK button

To remove a group from the system, click on the Manage Groups button, select the group you want to delete and click the Delete button.
Chapter 14. The command line

While Xubuntu, including the default applications and the applications in the Ubuntu repositories, comes with graphical user interfaces to accomplish most tasks, sometimes you might want or need to use a command line to achieve your goal - or just achieve it faster.

To start the default terminal emulator and get to the command line, either:

- Navigate to ➜ Accessories ➜ Terminal Emulator
- Press Alt+F2 and run xfce4-terminal

There is a great tutorial on using the command line [https://help.ubuntu.com/community/UsingTheTerminal] in the Ubuntu community wiki.

Running commands with administrative rights

When working on the command line, any command can be run as an administrator by prefixing the command with sudo. Sudo will remember your password for 15 minutes to allow you to perform multiple administrative tasks without being prompted for a password each time.

<table>
<thead>
<tr>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>If the program you wish to run as an administrator is graphical, such as the Mousepad text editor, run the command prefixed with pkexec in the command line. For example, to run Mousepad with administrative rights, run the command pkexec mousepad /path/to/file.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>Please note that for an application to run successfully with pkexec, it will need to ship a pkexec policy file. All default applications in Xubuntu that might need to be ran with administrative rights come with pkexec policy files.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Warning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Be careful when using sudo; you might damage your system if you type the wrong command! As a general rule, only use sudo when absolutely necessary. When you use sudo from a terminal, be sure to either close it when you have finished, or type exit to continue using that terminal with normal access powers.</td>
</tr>
</tbody>
</table>

For more information on sudo, see the sudo page [https://help.ubuntu.com/community/RootSudo] on the Ubuntu community wiki.

Common commands

Basic terminal commands are outlined below (square brackets indicate substitutions):

<table>
<thead>
<tr>
<th>Command: apt-cache</th>
</tr>
</thead>
<tbody>
<tr>
<td>What it does?</td>
</tr>
<tr>
<td>Syntax:</td>
</tr>
<tr>
<td>Command: apt-get</td>
</tr>
</tbody>
</table>
**The command line**

**What it does?**: Manages packages in apt. Common commands are install to install a package, remove to remove a package, purge to remove a package and the configuration, and autoremove which will also remove unneeded packages  
**Syntax**: `apt-get [command] [package]`  
**Command**: `cat`  
**What it does?**: Joins (concatenates) two or more files  
**Syntax**: `cat [file1] [file2] ... > [output file]`  
**Command**: `cd`  
**What it does?**: Changes to another directory  
**Syntax**: `cd [directory]`  
**Command**: `cp`  
**What it does?**: Copies a file (or files) to a directory or to overwrite another file  
**Syntax**: `cp [file(s)] [directory]`  
**Command**: `date`  
**What it does?**: Tells you the date and time in many different formats, timezones, and conversions.  
**Syntax**: `date [options]`  
**Command**: `editor`  
**What it does?**: Opens a text file in an editor  
**Syntax**: `editor [file]`  
**Command**: `grep`  
**What it does?**: Searches strings or files  
**Syntax**: `grep [text] [file(s)]` or `[command] | grep [text]`  
**Command**: `kill`  
**What it does?**: Terminates programs with a specified PID. If you don't know the PID you can use `pidof`  
**Syntax**: `kill [-SIGNAL] [PID(s)]`  
**Command**: `killall`  
**What it does?**: Much like the one above, except you specify the programs name  
**Syntax**: `killall [-SIGNAL] [process(es)]`  
**Command**: `less`  
**What it does?**: Shows the contents of a text file  
**Syntax**: `less [file]`  
**Command**: `ls`  
**What it does?**: Lists files in a directory. Lists files in the current directory if none is specified  
**Syntax**: `ls [directory]`  
**Command**: `man`  
**What it does?**: Shows help about a command  
**Syntax**: `man [command]`  
**Command**: `mv`  
**What it does?**: Moves or renames a file  
**Syntax**: `mv [filename] [newfilename]`  
**Command**: `rm`  
**What it does?**: Removes files or directories. Be very careful with this command! With the `-r` option, it removes all files and directories recursively!  
**Syntax**: `rm [file(s)]` or `rm -ir [dir(s)]`  
**Command**: `wget`
**What it does?** Downloads files to current directory. The -N option can be useful for checking to see if a file on the server is newer than the one you have locally, see `man wget` for more information.

**Syntax:** `wget [urls]`
### Appendix A. Application table

<table>
<thead>
<tr>
<th>Friendly name</th>
<th>Package name</th>
<th>Short description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Catfish File Search</td>
<td>catfish</td>
<td>File searching tool which is configurable via the command line</td>
</tr>
<tr>
<td>Document Viewer</td>
<td>evince</td>
<td>Document (PostScript, PDF) viewer</td>
</tr>
<tr>
<td>Calculator</td>
<td>gnome-calculator</td>
<td>Desktop calculator</td>
</tr>
<tr>
<td>Character Map</td>
<td>guucharmap</td>
<td>Unicode character picker and font browser</td>
</tr>
<tr>
<td>LibreOffice Calc</td>
<td>libreoffice-calc</td>
<td>Spreadsheet application</td>
</tr>
<tr>
<td>LibreOffice Writer</td>
<td>libreoffice-writer</td>
<td>Word processor</td>
</tr>
<tr>
<td>Mousepad</td>
<td>mousepad</td>
<td>Simple Xfce oriented text editor</td>
</tr>
<tr>
<td>PulseAudio Volume Control</td>
<td>pavucontrol</td>
<td>PulseAudio Volume Control</td>
</tr>
<tr>
<td>Simple Scan</td>
<td>simple-scan</td>
<td>Simple Scanning Utility</td>
</tr>
<tr>
<td>Application Finder</td>
<td>xfce4-appfinder</td>
<td>Find and launch applications installed on your system</td>
</tr>
<tr>
<td>Run Program</td>
<td>xfce4-appfinder</td>
<td>Run a program</td>
</tr>
<tr>
<td>Dictionary</td>
<td>xfce4-dict</td>
<td>Dictionary plugin for Xfce4 panel</td>
</tr>
<tr>
<td>Task Manager</td>
<td>xfce4-taskmanager</td>
<td>Process manager for the Xfce4 Desktop Environment</td>
</tr>
</tbody>
</table>

### Settings Manager

<table>
<thead>
<tr>
<th>Friendly name</th>
<th>Package name</th>
<th>Short description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Theme Configuration</td>
<td>gtk-theme-config</td>
<td></td>
</tr>
</tbody>
</table>

52
**Short description**: Simple interface to change GTK+ themes
**Friendly name**: Menu Editor
**Package name**: menulibre

**Short description**: Menu layout editor
**Friendly name**: About Me
**Package name**: mugshot

**Short description**: Lightweight user-configuration application
**Friendly name**: Network Connections
**Package name**: network-manager-gnome

**Short description**: Network management framework
**Friendly name**: Additional Drivers
**Package name**: software-properties-gtk

**Short description**: Configure third-party and proprietary drivers
**Friendly name**: Software & Updates
**Package name**: software-properties-gtk

**Short description**: Configure the sources for installable software and updates
**Friendly name**: Printers
**Package name**: system-config-printer-gnome

**Short description**: Printer configuration GUI

### Behind the scenes

**Package name**: gvfs-backends
**Short description**: Allows GVFS to connect to many network protocols (smb://, nfs://, etc)

**Package name**: gvfs-fuse
**Short description**: Let non-GNOME apps use GVFS via fuse

**Package name**: libnotify-bin
**Short description**: Binaries to send notification bubbles

**Package name**: light-locker
**Short description**: Simple session-locker for lightdm

**Package name**: tumbler
**Short description**: Xfce thumbnail daemon used by thunar and xfdesktop4

**Package name**: xfce4-notifyd
**Short description**: Daemon used to display notification bubbles

**Package name**: xfce4-indicator-plugin
**Short description**: Panel plugin for the indicators (indicator-application, indicator-sound)
Appendix B. Creative Commons by Attribution-ShareAlike 2.5

CREATIVE COMMONS CORPORATION IS NOT A LAW FIRM AND DOES NOT PROVIDE LEGAL SERVICES. DISTRIBUTION OF THIS LICENSE DOES NOT CREATE AN ATTORNEY-CLIENT RELATIONSHIP. CREATIVE COMMONS PROVIDES THIS INFORMATION ON AN "AS-IS" BASIS. CREATIVE COMMONS MAKES NO WARRANTIES REGARDING THE INFORMATION PROVIDED, AND DISCLAIMS LIABILITY FOR DAMAGES RESULTING FROM ITS USE.

License

THE WORK (AS DEFINED BELOW) IS PROVIDED UNDER THE TERMS OF THIS CREATIVE COMMONS PUBLIC LICENSE ("CCPL" OR "LICENSE"). THE WORK IS PROTECTED BY COPYRIGHT AND/OR OTHER APPLICABLE LAW. ANY USE OF THE WORK OTHER THAN AS AUTHORIZED UNDER THIS LICENSE OR COPYRIGHT LAW IS PROHIBITED.

BY EXERCISING ANY RIGHTS TO THE WORK PROVIDED HERE, YOU ACCEPT AND AGREE TO BE BOUND BY THE TERMS OF THIS LICENSE. THE LICENSOR GRANTS YOU THE RIGHTS CONTAINED HERE IN CONSIDERATION OF YOUR ACCEPTANCE OF SUCH TERMS AND CONDITIONS.

1. Definitions.

a. "Collective Work" means a work, such as a periodical issue, anthology or encyclopedia, in which the Work in its entirety in unmodified form, along with a number of other contributions, constituting separate and independent works in themselves, are assembled into a collective whole. A work that constitutes a Collective Work will not be considered a Derivative Work (as defined below) for the purposes of this License.

b. "Derivative Work" means a work based upon the Work or upon the Work and other pre-existing works, such as a translation, musical arrangement, dramatization, fictionalization, motion picture version, sound recording, art reproduction, abridgment, condensation, or any other form in which the Work may be recast, transformed, or adapted, except that a work that constitutes a Collective Work will not be considered a Derivative Work for the purpose of this License. For the avoidance of doubt, where the Work is a musical composition or sound recording, the synchronization of the Work in timed-relation with a moving image ("synching") will be considered a Derivative Work for the purpose of this License.

c. "Licensor" means the individual or entity that offers the Work under the terms of this License.

d. "Original Author" means the individual or entity who created the Work.

e. "Work" means the copyrightable work of authorship offered under the terms of this License.

f. "You" means an individual or entity exercising rights under this License who has not previously violated the terms of this License with respect to the Work, or who has received express permission from the Licensor to exercise rights under this License despite a previous violation.
g. "License Elements" means the following high-level license attributes as selected by Licensor and indicated in the title of this License: Attribution, ShareAlike.

2. Fair Use Rights. Nothing in this license is intended to reduce, limit, or restrict any rights arising from fair use, first sale or other limitations on the exclusive rights of the copyright owner under copyright law or other applicable laws.

3. License Grant. Subject to the terms and conditions of this License, Licensor hereby grants You a worldwide, royalty-free, non-exclusive, perpetual (for the duration of the applicable copyright) license to exercise the rights in the Work as stated below:

   a. to reproduce the Work, to incorporate the Work into one or more Collective Works, and to reproduce the Work as incorporated in the Collective Works;

   b. to create and reproduce Derivative Works;

   c. to distribute copies or phonorecords of, display publicly, perform publicly, and perform publicly by means of a digital audio transmission the Work including as incorporated in Collective Works;

   d. to distribute copies or phonorecords of, display publicly, perform publicly, and perform publicly by means of a digital audio transmission Derivative Works.

   e. For the avoidance of doubt, where the work is a musical composition:

      i. "Performance Royalties Under Blanket Licenses." Licensor waives the exclusive right to collect, whether individually or via a performance rights society (e.g. ASCAP, BMI, SESAC), royalties for the public performance or public digital performance (e.g. webcast) of the Work.

      ii. "Mechanical Rights and Statutory Royalties." Licensor waives the exclusive right to collect, whether individually or via a music rights society or designated agent (e.g. Harry Fox Agency), royalties for any phonorecord You create from the Work ("cover version") and distribute, subject to the compulsory license created by 17 USC Section 115 of the US Copyright Act (or the equivalent in other jurisdictions).

   f. "Webcasting Rights and Statutory Royalties." For the avoidance of doubt, where the Work is a sound recording, Licensor waives the exclusive right to collect, whether individually or via a performance-rights society (e.g. SoundExchange), royalties for the public digital performance (e.g. webcast) of the Work, subject to the compulsory license created by 17 USC Section 114 of the US Copyright Act (or the equivalent in other jurisdictions).

The above rights may be exercised in all media and formats whether now known or hereafter devised. The above rights include the right to make such modifications as are technically necessary to exercise the rights in other media and formats. All rights not expressly granted by Licensor are hereby reserved.

4. Restrictions. The license granted in Section 3 above is expressly made subject to and limited by the following restrictions:

   a. You may distribute, publicly display, publicly perform, or publicly digitally perform the Work only under the terms of this License, and You must include a copy of, or the Uniform Resource Identifier
for, this License with every copy or phonorecord of the Work You distribute, publicly display, publicly perform, or publicly digitally perform. You may not offer or impose any terms on the Work that alter or restrict the terms of this License or the recipients' exercise of the rights granted hereunder. You may not sublicense the Work. You must keep intact all notices that refer to this License and to the disclaimer of warranties. You may not distribute, publicly display, publicly perform, or publicly digitally perform the Work with any technological measures that control access or use of the Work in a manner inconsistent with the terms of this License Agreement. The above applies to the Work as incorporated in a Collective Work, but this does not require the Collective Work apart from the Work itself to be made subject to the terms of this License. If You create a Collective Work, upon notice from any Licensor You must, to the extent practicable, remove from the Collective Work any credit as required by clause 4(c), as requested. If You create a Derivative Work, upon notice from any Licensor You must, to the extent practicable, remove from the Derivative Work any credit as required by clause 4(c), as requested.

b. You may distribute, publicly display, publicly perform, or publicly digitally perform a Derivative Work only under the terms of this License, a later version of this License with the same License Elements as this License, or a Creative Commons iCommons license that contains the same License Elements as this License (e.g. Attribution-ShareAlike 2.5 Japan). You must include a copy of, or the Uniform Resource Identifier for, this License or other license specified in the previous sentence with every copy or phonorecord of each Derivative Work You distribute, publicly display, publicly perform, or publicly digitally perform. You may not offer or impose any terms on the Derivative Works that alter or restrict the terms of this License or the recipients' exercise of the rights granted hereunder, and You must keep intact all notices that refer to this License and to the disclaimer of warranties. You may not distribute, publicly display, publicly perform, or publicly digitally perform the Derivative Work with any technological measures that control access or use of the Work in a manner inconsistent with the terms of this License Agreement. The above applies to the Derivative Work as incorporated in a Collective Work, but this does not require the Collective Work apart from the Derivative Work itself to be made subject to the terms of this License.

c. If you distribute, publicly display, publicly perform, or publicly digitally perform the Work or any Derivative Works or Collective Works, You must keep intact all copyright notices for the Work and provide, reasonable to the medium or means You are utilizing: (i) the name of the Original Author (or pseudonym, if applicable) if supplied, and/or (ii) if the Original Author and/or Licensor designate another party or parties (e.g. a sponsor institute, publishing entity, journal) for attribution in Licensor's copyright notice, terms of service or by other reasonable means, the name of such party or parties; the title of the Work if supplied; to the extent reasonably practicable, the Uniform Resource Identifier, if any, that Licensor specifies to be associated with the Work, unless such URI does not refer to the copyright notice or licensing information for the Work; and in the case of a Derivative Work, a credit identifying the use of the Work in the Derivative Work (e.g., "French translation of the Work by Original Author," or "Screenplay based on original Work by Original Author"). Such credit may be implemented in any reasonable manner; provided, however, that in the case of a Derivative Work or Collective Work, at a minimum such credit will appear where any other comparable authorship credit appears and in a manner at least as prominent as such other comparable authorship credit.

5. **Representations, Warranties and Disclaimer**
UNLESS OTHERWISE AGREED TO BY THE PARTIES IN WRITING, LICENSOR OFFERS THE WORK AS-IS AND MAKES NO REPRESENTATIONS OR WARRANTIES OF ANY KIND CONCERNING THE MATERIALS, EXPRESS, IMPLIED, STATUTORY OR OTHERWISE, INCLUDING, WITHOUT LIMITATION, WARRANTIES OF TITLE, MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, NONINFRINGEMENT, OR THE ABSENCE OF LATENT OR OTHER DEFECTS, ACCURACY, OR THE PRESENCE OF ABSENCE OF ERRORS, WHETHER OR NOT DISCOVERABLE. SOME JURISDICTIONS DO NOT ALLOW THE EXCLUSION OF IMPLIED WARRANTIES, SO SUCH EXCLUSION MAY NOT APPLY TO YOU.

6. **Limitation on Liability.** EXCEPT TO THE EXTENT REQUIRED BY APPLICABLE LAW, IN NO EVENT WILL LICENSOR BE LIABLE TO YOU ON ANY LEGAL THEORY FOR ANY SPECIAL, INCIDENTAL, CONSEQUENTIAL, PUNITIVE OR EXEMPLARY DAMAGES ARISING OUT OF THIS LICENSE OR THE USE OF THE WORK, EVEN IF LICENSOR HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

7. **Termination**

   a. This License and the rights granted hereunder will terminate automatically upon any breach by You of the terms of this License. Individuals or entities who have received Derivative Works or Collective Works from You under this License, however, will not have their licenses terminated provided such individuals or entities remain in full compliance with those licenses. Sections 1, 2, 5, 6, 7, and 8 will survive any termination of this License.

   b. Subject to the above terms and conditions, the license granted here is perpetual (for the duration of the applicable copyright in the Work). Notwithstanding the above, Licensor reserves the right to release the Work under different license terms or to stop distributing the Work at any time; provided, however that any such election will not serve to withdraw this License (or any other license that has been, or is required to be, granted under the terms of this License), and this License will continue in full force and effect unless terminated as stated above.

8. **Miscellaneous**

   a. Each time You distribute or publicly digitally perform the Work or a Collective Work, the Licensor offers to the recipient a license to the Work on the same terms and conditions as the license granted to You under this License.

   b. Each time You distribute or publicly digitally perform a Derivative Work, Licensor offers to the recipient a license to the original Work on the same terms and conditions as the license granted to You under this License.

   c. If any provision of this License is invalid or unenforceable under applicable law, it shall not affect the validity or enforceability of the remainder of the terms of this License, and without further action by the parties to this agreement, such provision shall be reformed to the minimum extent necessary to make such provision valid and enforceable.

   d. No term or provision of this License shall be deemed waived and no breach consented to unless such waiver or consent shall be in writing and signed by the party to be charged with such waiver or consent.

   e. This License constitutes the entire agreement between the parties with respect to the Work licensed here. There are no understandings, agreements or representations with respect to the Work not
specified here. Licensor shall not be bound by any additional provisions that may appear in any communication from You. This License may not be modified without the mutual written agreement of the Licensor and You.

Creative Commons is not a party to this License, and makes no warranty whatsoever in connection with the Work. Creative Commons will not be liable to You or any party on any legal theory for any damages whatsoever, including without limitation any general, special, incidental or consequential damages arising in connection to this license. Notwithstanding the foregoing two (2) sentences, if Creative Commons has expressly identified itself as the Licensor hereunder, it shall have all rights and obligations of Licensor.

Except for the limited purpose of indicating to the public that the Work is licensed under the CCPL, neither party will use the trademark "Creative Commons" or any related trademark or logo of Creative Commons without the prior written consent of Creative Commons. Any permitted use will be in compliance with Creative Commons’ then-current trademark usage guidelines, as may be published on its website or otherwise made available upon request from time to time.

Creative Commons may be contacted at http://creativecommons.org/.